فریم ورک و CMSوردپرس

مشکل کار نکردن پلاگین ها در آپدیت وردپرس 5.5 و روش حل آن

وردپرس یکی از محبوب ترین سیستم های مدیریت محتوا در دنیا می باشد.تا به امروز نزدیک به ۳۰ درصد وب سایت ها و وبلاگ های دنیا با وردپرس طراحی و توسعه داده شده اند.اخیرا نسخه تیم وردپرس نسخه ۵.۵ این سیستم را منتشر کرد،که قرار بود به صورت کامل سرعت و عملکرد cms را به طرز چشم گیری افزایش دهد.

اما متاسفانه با اپدیت وردپرس به نسخه ۵.۵ بیشتر پلاگین های wordpress به خصوص پلاگین های کاربردی مثل یواست سئو،وی پی راکت و پلاگین مختلف از کار می افتادند با اطلاعاتی که مدیران وب سایت های وردپرسی به ما دادند مشخص شد که این مورد در اکثر وب سایت های طراحی شده با wordpress به وجود آمده است.

مشکل از کجاست؟

با بروزرسانی به نسخه ۵.۵ در واقع wordpress دیگر از جی کوئری به صورت همه گیر استفاده نمیکند و این موضوع باعث به وجود امدن مشکلات اساسی برای بسیاری از مدیران وب سایت شده است،این ممکن است به رفتارهای غیر منتظره در برخی موضوعات یا متصل شونده‌های موجود منجر شود که کد قدیمی‌تر را اجرا می‌کنند.

راه حل این مشکل

خوشبختانه برای حل این موضوع راه حلی وجود دارد شما می توانید با نصب پلاگین Enable jQuery Migrate Helper به صورت کامل این مشکل را تا بروز رسانی آینده برطرف کنید،تنها کافیست این پلاگین را از مخازن wordpress دانلود کرده ان را نصب و فعال کنید به همین سادگی.

در حال حاضر شما از the Enable jQuery Migrate Helper برای فعال کردن پشتیبانی از کد جاوا اسکریپت قدیمی استفاده می‌کنید که از توابع deprecated در کتابخانه jQuery جاوا اسکریپت استفاده می‌کند. شما در هنگام استفاده از مدیریت WordPress، هشدارها را در مورد این کارکردها خواهید دید که می توانید با استفاده از کنسول مرورگر تمامی این هشدار ها را یک به یک بررسی کنید.

 

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

دکمه بازگشت به بالا